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ABSTRACT
GaMField is an integrated system tool, released in 2011 and available
for free, able to construct and visualize subsurface sources in 3-D space
and to compute their gravimetric and magnetic effects. Since its first re-
lease, we have received feedback and new features implementation re-
quests from scientists worldwide. According to such requests,
significant advances have been introduced into the software to broaden
its field of  application in potential field analysis and interpretation as
described in this paper.

1. Introduction
GaMField was released in 2011 [Pignatelli et al.

2011] to realize the graphical windows-interactive con-
structions of  complex 3-D synthetic gravimetric and
magnetic sources. Such synthetic models are widely
used by researchers to verify potential data fields inter-
pretation algorithms and to predict magnetic or gravity
response of  a given geological model. [Last and Kubic
1983, Guillen and Menichetti 1984, Li and Oldenburg
1996, Fedi and Rapolla 1999, Pignatelli et al. 2007, Ni-
colosi et al. 2006].

The software can be freely downloaded, after the
registration, at the following URL:

http://geosoftware.sci.ingv.it
where a forum has been set-up for GaMField users and
for other possible future geophysical software applica-
tions. GaMField has been downloaded by hundreds of
users and it has got citations since its presentation [Ton-
tini 2012, Speranza et al. 2012, Al-Rahim 2013, Jesh-
vaghani and Darijani 2014, Speranza and Minelli 2014,
Guo et al. 2015, Liu et al. 2015, Montesinos et al. 2016,
Pan et al. 2016, Kim and Wessel 2016]. Many re-
searchers have joined the web forum and provided with
a large number of  comments and suggestions for im-

provements. We have collected these useful inputs and
decided to broaden GaMField field of  applications with
the aim to make it available to the scientific commu-
nity operating in the area of  potential field analysis and
interpretation.

Basically three main newly developed tools are
now implemented:

- use of  space vertical cross sections to build up
sources;
- a new interactive GUI to simulate topographic ef-
fects;
- STL 3D objects files import and export.
Minor additional improvements have been also in-

troduced. GaMField is maintained by INGV (Italian Na-
tional Institute of  Geophysics and Volcanology).

2. New tools description
An extensive description of  GaMField main prin-

ciples and its modules can be found in Pignatelli et al.
[2011] as well as in GaMField help. In Figure 1 a
schematic representation of  such modules and their
new inter-operative connections is shown.

The basic “GaMField idea” is using magnetic and
gravimetric field linearity to model complex sources us-
ing a set of  uniformly magnetized rectangular prisms.
The total intensity field at a given location is given by
the sum of  each prism field. The user can specifically set
up a calculation volume divided into equal rectangular
prisms (the source grid). Once such volume has been set
up, the user needs to select the prisms to build up a mag-
netic or a gravimetric source.

In order to select such prisms GaMField package
provides ModelBuilder module, shown in Figure 2 [Pig-
natelli et al. 2011] (see block “ModelBuilder” in Figure 1).



The source grid area is represented by a number
of  parallel horizontal planes filled with red and blue
tiles in Figure 2. Each tile is the top face of  a rectangu-
lar prism. Each prism extends up to the horizontal
plane beneath. At this stage, there are no magnetized

prisms and the different colours are there just to iden-
tify each prism boundary.

As shown in Figure 2, ModelBuilder allows select-
ing a horizontal layer by means of  the combo box out-
lined by the green circle.
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Figure 1. New GaMField modules and their inter-operative connections.

Figure 2. GaMField “ModelBuilder module”.
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After selecting the horizontal layer, ModelBuilder
lets the user select prisms by clicking them and allows
to assign separately to each prism a different magnetic
angle and magnetization/density values as outlined by
the red circle in Figure 2. The assignment is done by
clicking on the desidered prisms as shown in Figure 3.
Alternatively , selecting “Polygon” option in the “Se-
lection Mode” combo box, the user can also draw a
polygon and the software will automatically select all
the prisms inside it.

2.1 First upgrading feature: selecting prisms using ver-
tical section

As a lot of  geosoftware registered users have
pointed out, ModelBuilder module is very efficient when
building horizontally extended sources. Unfortunately,
it is not so efficient for vertically extended sources. In the
new GaMField version, we have added the possibility to
choose “Easting layers” or “Northing layers” as shown
in Figure 4 (see also block “Depth Northing Easting
slices” in Figure 1). As one can see in Figure 5, the new
ModelBuilder GUI shows a couple of  additional combo
boxes (indicated by the A frame) allowing such choice.

The “multiple Easting copy” and “multiple Nor-
thing copy” buttons (Figure 5, frame b)) can be used ex-
actly as described in Pignatelli et al. [2011] and in
GaMField help for “Multiple layer copy” button.

2.2 Second upgrading feature: topographic source gen-
eration

The old version of  GaMField was already provided
with some topographic simulation tools. A detailed de-
scription of  such tools can be found in Pignatelli et al.
[2011] and in GaMField help. Basically GaMField allows
loading a DEM file and automatically build up a set of
prisms approximating the loaded DEM in order to
compute the corresponding magnetic or gravimetric
field (see block “DEM import” in Figure 1). In the new
GaMField version, we have introduced a new tool
called “DemGenerator”, providing the user with the
possibility to interactively build a synthetic topographic
model “drawing” isolines (see block “DEM freehand
builder” in Figure 1). The model produced by this tool
is meant to be uniform so inclination, declination and
magnetization/density will be the same for the whole
built structure. The user could possibly introduce vari-

Figure 3. User can “magnetize prisms” of  a specific horizontal layer by clicking.
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ations using ModelBuilder module. The basic idea of
DemGenerator is to define a “top surface” and a “bot-
tom surface” as shown in Figure 6. The two surfaces
will define the top and the bottom of  the single layer of
prisms defining the DEM. Once the two surfaces have
been defined, this GaMField module will create uni-
formly dense/magnetized rectangular prisms with user
defined parameters. So basically, the following steps are
necessary to define a synthetic DEM:

- define an area where the two surfaces will be
built;
- define the prism horizontal sizes;
- define the whole DEM inclination, declination,

magnetization/density values;
- draw top and bottom surfaces by contouring;
- let DemGenerator build the DEM.
DemGenerator can be started by GaMField main

GUI by using the menu Topography -> Generate to-
pographic model. The GUI in Figure 7 will be called.

The text boxes defined in “Area details” are
needed to define the area where the topography will
be generated as well as the prisms size, whereas the
section “Dem details” allows the user to set the mag-
netization/density values of  the approximating
prisms. After filling in the above text boxes, the user
should confirm input parameters validity by clicking
“Confirm Parameters” button and then the top and
bottom surfaces can be defined. Basically it is needed
to write an altitude or depth into “Insert a top Isoline”

Figure 4. selecting prisms to be magnetized by means of  horizon-
tal or vertical sections.

Figure 5. The new ModelBuilder interface. A) The new combo
boxes “Easting” and “Northing” B) “Multiple Easting” and “Multiple
Northing” layer copy C) Susceptibility to Magnetization conversion
button.

Figure 6. Top and bottom surface.
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or “Insert a bottom Isoline” text box and click to the
button on the left of  the selected text box. It is impor-
tant to notice that vertical axis orientation is the same
as always used in GaMField, so the positive orientation
is downward. After clicking button, DemGenerator

will pop-up a figure showing the area coordinates and
the user can select the altitude/depth isoline by click-
ing as shown in Figure 8.

One can select as many points as needed and press
enter. The software will close the isoline connecting
the last clicked point to the first one as shown in Figure
9. When adding the next isolines, the software will
show the previous ones as shown in Figure 9.

Once the user has drawn all of  the isolines, “Cre-
ate Model” button needs to be clicked and the software
will generate a prisms ensemble approximating the se-
lected pattern (see example shown in Figure 10). Basi-
cally, the software will generate a single layer set of
prisms where the horizontal coordinates are quantized
according to “Area details” parameters and the prisms
top and bottom are calculated by a linear interpolation
of  the isolines defined surface.

The created model will be in GaMField and Mod-
elBuilder format so the user can send it to GaMField by
using “Send to GaMField” button or open it into Mod-
elBuilder by means of  “Modify with ModelBuilder”
button. In the first case, the model will be loaded from
GaMField main module as a topographic model, so the
computation has to be done by using the menu To-
pography -> Compute Topographic Magnetic Effects.
In the latter case, the user will be prompted to insert
the thickness resolution for the model and then the
software will open ModelBuilder and the user will be
able to modify the source as described in Pignatelli et
al. [2011] or in GaMField help. In this case, after send-
ing the final model to GaMField main module, the
field computation will be performed by using the
menu Compute -> Magnetic Field. Once a topo-
graphic model field has been computed, it can be ex-
ported into an ascii file by means of  the menu File ->
Save topographic effects.

Figure 7. The new tool DemGenerator.

Figure 8. Selecting isolines in DemGenerator module.

Figure 9. Selecting isolines in DemGenerator module.

Figure 10. Topographic model generated by DEMGenerator



2.2.1 Dem Generator: real coordinates tool
In order to make Dem generation easier and use-

ful for realistic simulation, in the new GaMField ver-
sion we have introduced the following possibilities:
(i) Build the topographic model using real coordinates;
(ii)Visualize real geographical topographies; (iii) Ex-
tract a topographic model from real DEM data.

The user has not to search or download any data,
he/she just needs an internet connection to use this
tool. Let’s assume, for example, the user wants to gen-
erate a synthetic DEM reproducing as much as possi-

ble Tenerife Island Volcanic area or build a generic to-
pographic model in the same zone. He/she just needs
to use “Real coordinates” button of  DEM Generator
module (see Figure 7) and the software will prompt
with the dialog box shown in Figure 11 asking for a
real rectangular area boundaries specified in geo-
graphic coordinates (the ones in Figure 11 refer to
Tenerife island).

After inserting such coordinates, the software will
automatically take care of  changing “Area details” text
boxes converting lat/lon coordinates into UTM pro-
jection of  the selected area to guarantee the selected
geographic area as DEM building domain. A message
box will be prompted to specify the UTM projection
zone. The user will be able to “draw” the isolines on
the background shown in the Figure 12:

As stated before, the “real DEM” background will
not affect any computation and the DEM creation is
exactly how described in the previous paragraph, how-
ever, if  the user wants to use the downloaded real
DEM as the topographic model to compute magnetic
or gravimetric field, he/she just needs to push “Extract
model” button. All the magnetic/gravimetric param-
eters chosen in DemGenerator gui will be used to
produce the topographic model. The only missing pa-
rameter is the bottom, so the user will be asked to in-
put it. The program will exclude from the model ev-
ery part of  the DEM where the top is lower than the
bottom chosen by the user.

It is important to state here that this feature uses
Mathworks web server mapping service. Basically,
matlab runtimes will automatically look for web
servers providing DEM data available at request mo-
ment. So this feature working depends on third parties
servers providing data, so we cannot guarantee a con-
stant and steady correct working. However, if  issues
occur, we will try to find possible solutions and, if  we
found them, provide upgrades to the users.

2.3. Third upgrading feature: STL files import and export
As reported by many users, even if  ModelBuilder

module is a very good and efficient tool to simulate
magnetic sources, sometimes users are already skilled
on different 3d modelling software. That’s why, in the
new version of  GaMField, we have introduced the pos-
sibility to import standard 3D model format files.

STL is a worldwide standard format for 3D trian-
gular mesh surfaces, largely used in CAD-CAM and 3D
printing manufacturing flows. Many editors, ranging
from simple freeware to high end production suites, do
exist to build and manipulate such meshes.
To load an STL file, the user has to use the menu
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Figure 11. Dialog box appearing when using DEMGenerator “Real
Coordinates” button. The right input parameters for Tenerife Island
are shown.

Figure 12. Isolines of  Tenerife Island to help user.
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File ->Model -> Load STL Model.
Some additional geometric parameters are entered

in the dialog window represented in Figure 13.
Once the parameters have been inserted, the STL

surface is converted to a set of  prisms as any other
GaMField model. The user can see the resulting model
by means of  View -> Built Model menu and perform
any other computation. Additionally, it is possible to ex-
port a ModelBuilder produced model as STL file using
command File ->Model -> Export model STL.

3. Additional minor changes to GaMField

3.1 Magnetization/susceptibility conversion
Another common requirement asked from

geosoftware forum members is about magnetic prop-
erties. The old version of  GaMField uses both magneti-
zation intensity and direction. Unfortunately, many re-
searchers use magnetic susceptibility. So we have inserted
the possibility to immediately convert the susceptibility
to magnetization. In the new version of  GaMField we
have introduced a suite tool to simplify the conversion.

Basically, given the magnetic body susceptibility, GaM-
Field perform the conversion to magnetization parame-
ters by means of  the following equations:

MT = MI + MR (1)

where MT is the total magnetization. MI is the source
magnetization induced by the external magnetic field
and MR is the source remanent magnetization. The re-
manent magnetization, if  wanted, should be intro-
duced by the user by means of  the three parameters:

|MR|: remanent magnetization intensity
IR: remanent magnetization inclination
DR: remanent magnetization declination

By means of  the previous parameters, it is possi-
ble to compute the three cartesian magnetization com-
ponents:

MRx = |MR| cos(IR) cos(DR) 
MRy = |MR| cos(IR) sin(DR) (2)
MRz = |MR| sin(IR)

MI is the main field induced magnetization. Its carte-
sian components are given by:

MIx = Bχ/μ cos (II) cos (DI)
MIy = Bχ/μ cos (II) sin (DI) (3)
MIz = Bχ/μ sin (II)

Where: B is the main magnetic field module, II is
the main magnetic field inclination, DI is the main mag-
netic field declination, χ is the source magnetic suscep-
tibility, µ is a constant given by: µ = 4π · 10−7 if  the
susceptibility is given in S.I.units, µ = 10−7 if  the sus-
ceptibility is given in c.g.s. units. Both unit systems can
be used in GaMField.

In GaMField, the user can perform such computa-
tion by using the ComputeMagneticParameters mod-
ule. It can be opened when working with ModelBuilder
module by means of  button Susc ->Magn Conv button
in ModelBuilder module or by “Special” menu in GaM-
Field main GUI. The ComputeMagneticParameters
GUI is represented in Figure 14. The user can input all
remanent magnetization, susceptibility and main field
parameters and then get the magnetization module
and angular values.

3.2 Set survey parameters from model
One issue identified by Geosoftware users is related

to possible source/model missed alignment. Basically,
when confirming the input parameters, GaMField
checks survey parameters and model parameters inde-
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Figure 13. STL import requester window.



pendently and does not perform any check to see if  the
model is located near the survey area. This can be very
annoying because the field can be computed very far
from the source area and it can happen especially when
a model has been loaded. In the new GaMField version,
we have implemented a menu to help the user. Basi-
cally, under the menu File -> Survey parameters we have
added the menu “Set from Model”. The software will au-
tomatically modify survey parameters to make the sur-
vey area roughly cover the loaded source. The user can
further modify the survey parameters if  he/she likes.

3.3 Unify two or more models
This feature could be very advantageous when the

user needs to build two models geographically very far
or having very different shapes so that it is inconvenient
to use the same ModelBuilder session to realize them.
In this case, let’s assume we have two or more models

for GaMField (produced externally or by using
ModelBuilder), we just need to use the menu
File -> Model -> Unify two models or the menu File -
> Model -> Unify more models. The software will auto-
matically produce a single model including both of  them.

3.4 Change whole source magnetic parameters
It has come out from users that sometimes the

source produced needs to be changed in terms of  in-
clination, declination or magnetization. Basically the
user wants to change one or more of  such parameters
without modifying structure geometry. In the new ver-
sion of  GaMField, one can find such feature in Model-
Builder, under the buttons “Change Inclination”,
“Change Declination” and “Change Magnetization”.
The software will ask for parameters to be used and a
confirmation from the user.

3.5 Analytical signal
In the new GaMField version, the Analytical signal

computation has been added. The user has not to follow
any specific instruction but it will be computed only if
the “Compute Gradients” check box is selected. Then
the analytical signal could be saved or visualized by
means of  the two menu View -> Complete Model ef-
fects and View -> Complete DEM effects as all other
computed components.

3.6 Fields comparing tool
A nice tool suggested by many users is the possi-

bility to save different fields computed during the work-
ing session and compare them. For example, we would
like to compare the field generated by the same model
but at different elevations. In this GaMField version we
have added the possibility to insert one or more fields
into “history” which will be stored during the session.
The way to do it is by using menu Special -> Add Field
to History, Once this menu has been selected, GaMField
asks for a note to label such field. It is very important for
the user to choose a note expressing the field details. For
example a good note could be “Magnetic Field Altitude
300 m” as shown in the Figure 15.

If  the user wants to compare some stored fields
he/she needs to use menu Special -> Compare Fields
tool and select the fields he/she wants to compare by
means of  the combo box shown in Figure 16

4. Conclusions
GaMField was freely released for the first time

about six years ago and a lot of  users have been regis-
tered at website http://geosoftware.sci.ingv.it to down-
load it. During these years, we have received a lot of

PIGNATELLI ET AL.

8

Figure 14. ComputeMagneticParameters module. The user can
input all susceptibility, remanent magnetization and main field pa-
rameters and then compute the magnetization parameters by using
“Compute” button.

Figure 15. Add history dialog.

Figure 16. Fields compare module.



9

positive feedback and improvement proposals. This cir-
cumstance triggered the effort to release a new version
of  the software where additional useful tools have been
integrated and made available to the scientific commu-
nity through the same forum.

References
Al-Rahim, A. M. (2013). Locating of  promising strati-
graphic traps of  pinch-out type in Iraq-new sense.
Arabian Journal of  Geosciences, 6(5):1381–1393.

Fedi, M. and Rapolla, A. (1999). 3d inversion of  gravity
and magnetic data with depth resolution. Geo-
physics, 64:452–460.

Guillen, A. and Menichetti, V. (1984). Gravity and mag-
netic inversion with minimization of  a specific func-
tional. Geophysics, 49:1354–1360.

Guo, Z.-Y., Liu, D.-J., Pan, Q., and  Zhang, Y.-Y. (2015).
Forward modeling of  total magnetic anomaly over
a pseudo-2D underground ferromagnetic pipeline.
Journal of  Applied Geophysics, 113:14–30.

Jeshvaghani, M. S. and Darijani, M (2014). Two-dimen-
sional geomagnetic forward modeling using adap-
tive finite element method and investigation of  the
topographic effect. Journal of  Applied Geophysics,
105:169–179.

Kim, S.-S. and Wessel, P. (2016). New analytic solutions
for modeling vertical gravity gradient anomalies.
Geochemistry Geophysics Geosystems, 17(5):1915–
1924.

Last, B. and Kubic, K. (1983). Compact gravity inver-
sion. Geophysics, 48:713– 721.

Li, Y. and Oldenburg, D. (1996). 3-d inversion of  mag-
netic data. Geophysics, 61:394–407.

Liu, S., Hu, X., Xi, Y., and Liu, T. (2015). 2D inverse
modeling for potential fields on rugged observation
surface using constrained Delaunay triangulation.
Computers & Geosciences, 76:18–30.

Montesinos, F. G., Blanco-Montenegro, I., and Arnoso,
J. (2016). Three- dimensional inverse modelling of
magnetic anomaly sources based on a genetic algo-
rithm. Physics of  The Earth and Planetary Interiors,
253:74–87.

Nicolosi, I., Blanco-Montenegro, I., Pignatelli, A., and
Chiappini, M. (2006). Estimating the magnetization
direction of  crustal structures by means of  an equiv-
alent source algorithm. Physics of  the Earth and
Planetary Interiors, 155:163–169.

Pan, Q., Liu, D.-J., Guo, Z.-Y., Fang, H.-F., and Feng, M.-
Q. (2016). Magnetic anomaly inversion using mag-
netic dipole reconstruction based on the pipeline
section segmentation method. Journal of  Geo-
physics and Engineering, 13(3):242–258.

Pignatelli, A., Nicolosi, I., Carluccio, R., Chiappini, M.,
and von Frese, R. (2011). Graphical interactive gen-
eration of  gravity and magnetic fields. Computers
& Geosciences, 37, issue 4:567–572.

Pignatelli, A., Nicolosi, I., and Chiappini, M. (2007). An
alternative 3-d source inversion of  magnetic anoma-
lies method with depth resolution. Annales of  Geo-
physics, 49:1021– 1027.

Speranza, F. and Minelli, L. (2014). Ultra-thick Triassic
dolomites control the rupture behavior of  the cen-
tral Apennine seismicity: Evidence from magnetic
modeling of  the L’Aquila fault zone. Journal Of
Geophysical Research-Solid Earth, 119(9):6756–
6770.

Speranza, F., Minelli, L., Pignatelli, A., and Chiappini,
M. (2012). The Ionian Sea: The oldest in situ ocean
fragment of  the world? Journal of  Geophysical Re-
search-Solid Earth, 117.

Tontini, F. C. (2012).Rapid interactive modeling of  3D
magnetic anomalies. Computers & Geosciences,
48:308–315.

*Corresponding author: Alessandro Pignatelli,
Istituto Nazionale di Geofisica e Vulcanologia, Roma, Italy;
email: alessandro.pignatelli@ingv.it.

© 2018 by the Istituto Nazionale di Geofisica e Vulcanologia. All
rights reserved.

GAMFIELD 2.0 - SIGNIFICANT ADVANCES


